BLOG


Rendercore Lab Now Supports Blender 2.77a!

blender277a

Rendercore Lab now supports Blender 2.77a . Older versions of Blender are also supported. We don’t support Blender Cycles for GPU, only for CPU rendering.

View Job Submission Manual